Post Title Replies / Views Last Reply Info
[SOLVED] WinCustomize.com browse problem
Dec 10, 2013
1 Replies
1,529 Views
Dec 11, 2013
Is there any way to get the forums to display 100 posts per page?
Nov 15, 2013
2 Replies
1,563 Views
Nov 17, 2013
Some notes about the GalCiv 2/3 forums.
Nov 11, 2013
9 Replies
3,150 Views
Nov 15, 2013
Elemental Site Forum Issues (Chrome?)
Nov 8, 2013
2 Replies
1,559 Views
Nov 8, 2013
how to install CustoPacks on the computer?
Oct 25, 2013
3 Replies
1,330 Views
Oct 25, 2013
How do I delete some of my posts
Oct 24, 2013
6 Replies
1,869 Views
Oct 25, 2013
GalCiv III Forums - Go To Last Post button doesn't show
Oct 21, 2013
0 Replies
715 Views
Oct 21, 2013
Direct link to post issue
Oct 16, 2013
3 Replies
990 Views
Oct 21, 2013
Karma not working on Galactic Civilizations III Forums
Oct 17, 2013
0 Replies
432 Views
Oct 17, 2013
Cannot Mark all posts as read
Oct 16, 2013
5 Replies
1,206 Views
Oct 16, 2013
Avatar picture not updating on FE forums
Mar 25, 2013
6 Replies
1,381 Views
Oct 16, 2013
Error trying to give karma on forums.galciv3.com
Oct 16, 2013
0 Replies
326 Views
Oct 16, 2013
getting message forums are down for maintenance at work
Sep 16, 2013
14 Replies
2,852 Views
Sep 18, 2013
Can't figure out how to unlock "Personal Page"--can't favourite any themes.
Sep 3, 2013
5 Replies
1,364 Views
Sep 3, 2013
[Forum BUG] "Did you know that your Internet Explorer is out of date?"
Aug 8, 2013
12 Replies
3,193 Views
Aug 11, 2013
Forum feedback and suggestions
Jul 21, 2013
5 Replies
3,764 Views
Aug 2, 2013
email expired
Jul 3, 2013
8 Replies
1,857 Views
Jul 5, 2013
Unable to read any forum posts [resolved]
Jun 4, 2013
9 Replies
2,031 Views
Jun 5, 2013
Who's the MOD in charge...
May 14, 2013
9 Replies
2,274 Views
May 17, 2013
Editing Posts
May 2, 2013
12
44 Replies
12,936 Views
May 3, 2013
Forum Changes
Apr 9, 2013
12
44 Replies
25,644 Views
Apr 16, 2013
Login Issues
Apr 15, 2013
7 Replies
1,230 Views
Apr 16, 2013
Cannot post comment in WB Skins section
Apr 2, 2013
12
33 Replies
9,728 Views
Apr 3, 2013
Fehlende Dream Upload's
Mar 18, 2013
5 Replies
865 Views
Mar 19, 2013
Missing forum features?
Feb 5, 2013
123» Last
134 Replies
23,859 Views
Mar 11, 2013
"Login" doesn't log into forums and
Mar 6, 2013
2 Replies
913 Views
Mar 7, 2013
My Avatar Picture Upload
Aug 19, 2010
12
48 Replies
12,200 Views
Feb 27, 2013
http://www.elementalgame.com broken
Feb 13, 2013
9 Replies
1,661 Views
Feb 14, 2013
Skins List Issue
Feb 4, 2013
6 Replies
1,156 Views
Feb 8, 2013
Password too long
May 21, 2012
4 Replies
1,251 Views
Feb 1, 2013
have windowblinds and can't download anything!
Jan 13, 2013
6 Replies
1,468 Views
Jan 13, 2013
Cannot login in on the Sins of a Solar Empire forums! Help!!!
Dec 28, 2012
18 Replies
4,197 Views
Dec 30, 2012
Long-dead topics keep coming back
Dec 20, 2012
12
35 Replies
9,446 Views
Dec 23, 2012
Now I can't comment on skins.
Dec 19, 2012
12 Replies
1,393 Views
Dec 20, 2012
Avatar image problems tonight
Sep 19, 2012
12
41 Replies
7,686 Views
Dec 14, 2012
Reporting PM spam?
Dec 13, 2012
3 Replies
978 Views
Dec 13, 2012
Skins List Issue
Nov 9, 2012
25 Replies
4,402 Views
Nov 20, 2012
Adding Comments or Replying to Comments Not Working
Jul 10, 2012
17 Replies
2,793 Views
Nov 14, 2012
Some replys/comments appearing in wrong position?
Nov 9, 2012
6 Replies
1,229 Views
Nov 9, 2012
Error 401 when trying to change profile avatar
Feb 22, 2012
15 Replies
2,170 Views
Nov 4, 2012
forum replies by e-mail ?
Nov 1, 2012
1 Replies
939 Views
Nov 1, 2012
[GRIPE] Trying to put together a how-to guide with screenshots is a lot of work ...
Oct 25, 2012
6 Replies
1,072 Views
Oct 25, 2012
Weird Stuff On WinCustomize Forums
Sep 24, 2012
22 Replies
4,233 Views
Sep 27, 2012
WYSIWYG quoting
Sep 18, 2012
12 Replies
1,616 Views
Sep 26, 2012
My Replies link on the fritz
Sep 21, 2012
5 Replies
1,104 Views
Sep 21, 2012
Problem with Metaverse Empire Logo's
Aug 24, 2012
22 Replies
5,499 Views
Sep 10, 2012
Hotmail.com turns to outlook.com
Aug 1, 2012
6 Replies
2,462 Views
Aug 27, 2012
Grey Dead Spaces
Jul 30, 2012
12
28 Replies
4,427 Views
Aug 1, 2012
Improper site rendering, multiple browsers
Aug 1, 2012
13 Replies
1,611 Views
Aug 1, 2012
Topic "Read" Status Updating Very Sloooowly
Jul 30, 2012
5 Replies
1,184 Views
Jul 30, 2012
Moderators for Forum Issues..
Icon Legend - Click To Show
Stardock Forums v1.0.0.0    #108491  web02   Server Load Time: 00:00:00   Page Render Time: